Navigation
 Startseite
 Fachbücher
 Forum
 Webmaster News
 Script Newsletter
 Kontakt
 Script Installation
 Php
 Php Tutorials
 Impressum

Community-Bereich
 kostenlos Registrieren
 Anmelden
 Benutzerliste

Script Datenbank
 Script Archiv
 Script Top 20
 Screenshots
 Testberichte

Suche
 
Script Seite

Unsere Php Scripts
 Counter Script
 Umfrage Script
 Bilder Upload Script
 Terminverwaltung
 Simple PHP Forum
 RSS Grabber

Script Mods
 phpBB Adsense Mode

Tools und Generatoren
 .htpasswd Generator
 md5 Generator
 base64 Generator
 ICQ Generator
 Colorpicker
 Unix timestamp Tool
 TLD Liste
 Webkatalog Verzeichnis

Partner
Sprüche Treff

Hosterplus.de
Bekommen Sie Speicherplatz (Webspace), Domains und...
http://www.Hosterplus.de
Artfiles.de
Bietet Serviceorientierte Internetdienstleistungen...
http://www.Artfiles.de
 
 
 

Erfahrungsbericht/Problemlösung über Update von 2.8.6 bis 2.9.2 des Wordpress Script

Sie befinden sich: Home > Webmaster News

So heute Abend wollte ich ein Testbericht von Wordpress Script schreiben, dies hatte ich mir bereits schon vor paar Tagen vorgenommen und eine Standardinstallation der Version 2.8.6 auf meinen lokalen Rechner gemacht. Nach den ich heute ein wenig Zeit dafür gefunden hatte und mich entsprechend, in den Administrationsbereich vom Wordpress Script eingeloggt hatte, habe ich mit Erstaunen festgestellt das folgende Fehlermeldung kommt:

Warning: gzinflate() [<function.gzinflate>]: data error in .../wp-includes/http.php on line 1787

Nun ja, so ein Mist ich hätte vielleicht Xampp nicht vorher ein Update auf die neueste Version spendieren sollen. Aber egal, dachte ich mir "Mache ich einfach mal ein Update auf die neuste Version".

Als erstes bin ich auf die Webseite https://static.wordpress-deutschland.org/upgradepaket/ gegangen und habe mir die Zip Datei "fix-29-to-291.zip" heruntergeladen. Nach dem ich ein Backup des aktuellen Script gemacht hatte, habe ich alle Dateien überschrieben und entsprechend die Update-Routine unter der Adresse "/wp-admin/upgrade.php" aufgerufen.

Danach habe ich folgende Fehlermeldung erhalten beim Ausführen der update.php:

WordPress Datenbank-Fehler: [ALTER TABLE causes auto_increment resequencing, resulting in duplicate entry '41' for key 'PRIMARY']
ALTER TABLE wp_options DROP PRIMARY KEY, ADD PRIMARY KEY(option_id)

So der nächste Fehler ... :-(

Aber naja ist ja nur ein Schlüssel der nicht gesetzt werden konnte in der Tabelle wp_options. Daraufhin habe ich einfach das nächste Update "fix-291-to-292.zip" herunter geladen und genauso ausgeführt. Hierbei kam direkt automatisch der nächste Fehler:

Fatal error: Call to undefined function: is_admin() in .../wp-includes/vars.php on line 16

Die Fehlermeldung sagt nur aus, dass die Funktion "is_admin()" nicht definiert ist in der Datei vars.php. Ist schon sehr toll, irgendwie habe ich ausschließlich Pech mit den updaten. Vielleicht ist dies nicht mein Tag.

Auf der Suche nach einer Problemlösung, bin ich auf einen Beitrag in WordPress Supportforum gestoßen, wo drauf hingewiesen wurde die aktuelle Gesamte-Version 2.9.2 herunter zu laden und alle Dateien nochmal zu überschreiben. Danach sollte man ausschließlich die Update-Routine ausführen. Dies habe ich dann auch so umgesetzt und siehe da, mein Wordpress Script läuft wieder. Ich hoffe dass ihr nicht solche Probleme beim Ausführen des Updates von Wordpress habt.

Eingetragen am 25.05.2010


Schreib ein Kommentar

Name
Mail
Webseite
Kommentar